Help with graphical glitch, rune factory 2.

Ask questions about DraStic or discuss compatibility issues here.
Post Reply
Posts: 1
Joined: Wed Feb 02, 2022 9:41 am

Help with graphical glitch, rune factory 2.

Post by Pafie » Wed Feb 02, 2022 12:11 pm

So I'm having a graphical problem in rune factory 2

Example video

As you can see talking to npc's or triggering cutscenes causes the shadows to glitch and changing locations will remedy this.
Using tools has no effect and any npc will trigger the glitch.

The videos shows segments from:
the opening cutscene - no visual glitch despite being a cutscene.
The tutorial when your first able to talk to an npc - the glitch can be triggered anytime after this point.
(Theirs a small walking segment between these two scenes but no npcs or cutscenes to trigger the glitch)
After finishing the tutorial (time is now running otherwise no difference) - I use a tool to show its uneffected by menus and actions (I fumble a bit opening the menu) and then I trigger a cutscene in town indoors to show its not only when outside.
Finally I open the menu to show the video settings are all off.

I had some of the video enhancement settings on when I first discovered this and I've tried turning them all on and off in various combinations, for the sake of the example video I have all of them turned off. (Shown at the end)

I'm playing on a real phone, Samsung Galaxy S20FE 5G.
And if I run the game through retroarch via desmume the glitch doesn't appear.

I'm not sure how to fix this if theirs even anything I can do and would apriciate some help. ... pBLDm6e9eM
Here ^ I've included the rom and a save state from my Gdrive (the attachments option is saying something about the limit being reached and I can't add a file) that starts you from the first opportunity to speak to an npc, if you restart you can see the error in less then 3 minutes (without speedup) from a new save as the opening cutscene is short and you can trigger the glitch by talking to either of the npc's in the tutorial. (I've never shared a savestate before so if theirs something I've forgotten or missed let me know and I'll add it) (The rom is because I renamed the original for sorting purposes and don't remember exactly the one I got originaly, so incase it has to be the same rom I've included it (the original was the regular rom (not undub) from cdromance if you'd like to or need to download it yourself)

Most likely this is either cause by an update from the app or the specific phone I'm playing on as their are a couple entries in the compatability forum says the game has no problems for them.

Forgot to put this somewhere higher up but this is a photo of my main menu for the version I'm playing (r2.5.2.2a)

Post Reply