Mapping issues with Ipega Red Knight PG-9087S

Ask questions about DraStic or discuss compatibility issues here.
Post Reply
Greikman
Posts: 2
Joined: Thu May 23, 2019 8:19 am

Mapping issues with Ipega Red Knight PG-9087S

Post by Greikman » Thu May 23, 2019 8:23 am

I just got an ipega controller and Iv noticed that no matter what I press on the controller it wont map.
I attempted to use it without mapping and one or two buttons do work (though they do seemingly random things each time I press them)

I have tried to search for ways to fix this but came back empty handed, does anyone know?

TheICSDI
Posts: 1
Joined: Fri Aug 23, 2019 7:15 am

Re: Mapping issues with Ipega Red Knight PG-9087S

Post by TheICSDI » Fri Aug 23, 2019 7:22 am

I'm having the same problem. Did you find a way to fix it?

Greikman
Posts: 2
Joined: Thu May 23, 2019 8:19 am

Re: Mapping issues with Ipega Red Knight PG-9087S

Post by Greikman » Mon Aug 26, 2019 5:42 pm

TheICSDI wrote:
Fri Aug 23, 2019 7:22 am
I'm having the same problem. Did you find a way to fix it?
I got it fixed but I had a hard time knowing how.
From what I can gather, the controller goes through its own first-time setup whenever you turn it on for the first time. Give it time to finish, some 15 minutes on.
Then just charge it for a while longer and every now and then connect it and see if it works, eventually, when it is charged at 100%, the controller just works. Prob is a software thing but honestly im not sure.

tomongo
Posts: 1
Joined: Thu Nov 07, 2019 2:49 am

Re: Mapping issues with Ipega Red Knight PG-9087S

Post by tomongo » Thu Nov 07, 2019 2:54 am

I realize I'm late to the party, but what you have to do is: Charge the controller up to 100%, put the controller into mode 3 using home + X, and then pair it with your device.

Post Reply