Help! Won't load past startup r2.5.0.3a

Ask questions about DraStic or discuss compatibility issues here.
User avatar
dsattorney
Posts: 313
Joined: Thu Aug 03, 2017 11:29 am
Location: Argentina
Contact:

Re: Help! Won't load past startup r2.5.0.3a

Post by dsattorney » Mon Jul 02, 2018 12:29 pm

And install a pre-10.7 version if you want.
OBJECTION!
Image
Other places to find me:
VOGONS: http://www.vogons.org/ (as olddos25)

marioalarcao
Posts: 1
Joined: Mon Jul 02, 2018 12:50 pm

Re: Help! Won't load past startup r2.5.0.3a

Post by marioalarcao » Mon Jul 02, 2018 12:52 pm

Man... you must be kidding that was just this easy! Why would you do this Google Play Store? I totally blamed the developers! Thank you guys! My Zelda's games are as thankful as me!

Mi4u
Posts: 2
Joined: Sun Jul 01, 2018 9:54 am

Re: Help! Won't load past startup r2.5.0.3a

Post by Mi4u » Mon Jul 02, 2018 1:15 pm

downgraded google play and it works perfectly fine now thanks!

Pushan
Posts: 3
Joined: Mon Jul 02, 2018 5:04 am

Re: Help! Won't load past startup r2.5.0.3a

Post by Pushan » Mon Jul 02, 2018 2:12 pm

Thanks I got it... It works perfectly fine now...
Hope Google resolves the issue soon

User avatar
dsattorney
Posts: 313
Joined: Thu Aug 03, 2017 11:29 am
Location: Argentina
Contact:

Re: Help! Won't load past startup r2.5.0.3a

Post by dsattorney » Mon Jul 02, 2018 2:43 pm

It's nice to see some happy faces in the end. Including mine! :D
OBJECTION!
Image
Other places to find me:
VOGONS: http://www.vogons.org/ (as olddos25)

SephMiguel
Posts: 8
Joined: Fri Jun 29, 2018 5:00 am

Re: Help! Won't load past startup r2.5.0.3a

Post by SephMiguel » Mon Jul 02, 2018 2:52 pm

Dang, I can't downgrade past 10.7.17, I guess because I installed gapps recently. Any idea what I can do? Nice to know there's a solution tho.

User avatar
dsattorney
Posts: 313
Joined: Thu Aug 03, 2017 11:29 am
Location: Argentina
Contact:

Re: Help! Won't load past startup r2.5.0.3a

Post by dsattorney » Mon Jul 02, 2018 3:23 pm

Tell us a bit more about your problem.
OBJECTION!
Image
Other places to find me:
VOGONS: http://www.vogons.org/ (as olddos25)

SephMiguel
Posts: 8
Joined: Fri Jun 29, 2018 5:00 am

Re: Help! Won't load past startup r2.5.0.3a

Post by SephMiguel » Mon Jul 02, 2018 3:36 pm

I did what tomkatt said and disabled google play, it promoted me to roll back to factory default, but it's still 10.7.17. I guess I can just wait, since this seems like a major fuckup from Google, can't imagine they'll take too long to fix it.

SephMiguel
Posts: 8
Joined: Fri Jun 29, 2018 5:00 am

Re: Help! Won't load past startup r2.5.0.3a

Post by SephMiguel » Mon Jul 02, 2018 6:13 pm

Well nevermind, fixed for me. I had to uninstall play store and install the older version from an apk, but it works now! Thanks guys :)

User avatar
kaikun97
Posts: 544
Joined: Thu Dec 26, 2013 11:41 am
Location: England

Re: Help! Won't load past startup r2.5.0.3a

Post by kaikun97 » Tue Jul 03, 2018 2:36 am

Everyone who does not want to wait for the update, please try this Google Play Store v10.7.19 version APK. It reportedly now has the issue fixed. This is a signed APK and should be able to install fine as an update.

https://www.apkmirror.com/apk/google-in ... 9-release/

This issue has made it to XDA so it must be a pretty
widespread issue now. Google says they are investigating the issue now.

https://www.xda-developers.com/latest-p ... paid-apps/

Post Reply