Troubleshooting crashes/sudden closes and other problems

Ask questions about DraStic or discuss compatibility issues here.
User avatar
kaikun97
Posts: 679
Joined: Thu Dec 26, 2013 11:41 am
Location: England

Re: Troubleshooting crashes/sudden closes and other problems

Post by kaikun97 » Thu Aug 27, 2020 5:18 am

DanielFerVP wrote:
Thu Aug 27, 2020 12:04 am
Device: Huawei Mate 20 Lite
Problem: I'm tryng to start a new game, but every time, I tried it restart the app.
Even I tried all the solutions, but it didn't work.

A week ago, I was playing normally, I don't know, what's happening.
Which game doesn't work?

DanielFerVP
Posts: 4
Joined: Wed Aug 26, 2020 11:55 pm

Re: Troubleshooting crashes/sudden closes and other problems

Post by DanielFerVP » Thu Aug 27, 2020 1:28 pm

kaikun97 wrote:
Thu Aug 27, 2020 5:18 am
DanielFerVP wrote:
Thu Aug 27, 2020 12:04 am
Device: Huawei Mate 20 Lite
Problem: I'm tryng to start a new game, but every time, I tried it restart the app.
Even I tried all the solutions, but it didn't work.

A week ago, I was playing normally, I don't know, what's happening.
Which game doesn't work?
All games, I can't play anything.
When I'm launch the app, and tap "new game", it takes me out.

User avatar
kaikun97
Posts: 679
Joined: Thu Dec 26, 2013 11:41 am
Location: England

Re: Troubleshooting crashes/sudden closes and other problems

Post by kaikun97 » Thu Aug 27, 2020 1:30 pm

DanielFerVP wrote:
Thu Aug 27, 2020 1:28 pm
kaikun97 wrote:
Thu Aug 27, 2020 5:18 am
DanielFerVP wrote:
Thu Aug 27, 2020 12:04 am
Device: Huawei Mate 20 Lite
Problem: I'm tryng to start a new game, but every time, I tried it restart the app.
Even I tried all the solutions, but it didn't work.

A week ago, I was playing normally, I don't know, what's happening.
Which game doesn't work?
All games, I can't play anything.
When I'm launch the app, and tap "new game", it takes me out.
Even after deleting and reinstalling the app and deleting the Drastic folder on your phone storage (it will delete your saves though.)
Did you phone also get an update before it stopped working?

DanielFerVP
Posts: 4
Joined: Wed Aug 26, 2020 11:55 pm

Re: Troubleshooting crashes/sudden closes and other problems

Post by DanielFerVP » Thu Aug 27, 2020 1:50 pm

kaikun97 wrote:
Thu Aug 27, 2020 1:30 pm
DanielFerVP wrote:
Thu Aug 27, 2020 1:28 pm
kaikun97 wrote:
Thu Aug 27, 2020 5:18 am


Which game doesn't work?
All games, I can't play anything.
When I'm launch the app, and tap "new game", it takes me out.
Even after deleting and reinstalling the app and deleting the Drastic folder on your phone storage (it will delete your saves though.)
Did you phone also get an update before it stopped working?
Yes, I deleted all, reinstalled, but stills without working.
I remember that my phone got an update recently, but I'm not shure if that was before or after the problem.

Wolftheotter
Posts: 2
Joined: Thu Aug 20, 2020 6:24 pm

Re: Troubleshooting crashes/sudden closes and other problems

Post by Wolftheotter » Sat Aug 29, 2020 8:05 pm

Wolftheotter wrote:
Thu Aug 20, 2020 6:31 pm
Hey, having an issue with my Nvidia shield portable running drastic. Used to work wonderfully, but now when I try to start a game I am sent to my home screen. I am on 4.4.2 if that matters. I was able to find a drastic demo version online and it works fine.

The app itself does not close, and it still shows when I look at my multitasking trey. This is the only crash report I have, but it could be unrelated as whatever this bug is does not cause drastic to crash.

Unhandled SIG_SEGV in 'Tony Hawk's Proving Ground'
caused by instruction stmib r2, {r0 - r1} (at 6e502730), address 8732a26c
Version: r2.5.2.2a build 104
Reference: 5F64A5E4
Registers:
r00: 00000008
r01: 00000ECA
r02: 8732A268
r03: 03808A4C
r04: 7290E928
r05: 6B2E5008
r06: 7291CB50
r07: 00000088
r08: 6E5FC0F0
r09: 5F5E4EB4
r10: 5F5CB5F8
r11: 6294AB24
r12: 03808A4D
r13: 6294AA70
r14: 6E503E8C

Emulated ARM9:
Mode 00, IRQ 00000001, CPSR a000001f, PC 0200a1f0, cycles -0000001
r0: 00000000
r1: 0000001f
r2: 00000000
r3: 00000000
r4: 00000000
r5: 00000000
r6: 00000000
r7: 00000000
r8: 00000000
r9: 00000000
r10: 00000000
r11: 00000000
r12: 00000000
r13: 020baec8
r14: 02008d2f
r15: ffff0640
Debug instruction count: 0

Emulated ARM7:
Mode 00, IRQ 00000001, CPSR 8000001f, PC 00001158, cycles -0000001
r0: 04000000
r1: 03808788
r2: 00000080
r3: 00000007
r4: 0000001f
r5: 00000070
r6: 00000001
r7: 0380f958
r8: 0000ffff
r9: 00000002
r10: 00000000
r11: 00000000
r12: 00000006
r13: 0380f940
r14: 037f8454
r15: 00001f10
Debug instruction count: 0


Translation cache details:
main: 0x5f824000 - 0x60824000
main: 0 + 0 bytes
itcm: 0x60824000 - 0x60924000
itcm: 0 + 0 bytes
alternate: 0x60924000 - 0x60b24000
alternate: 632 + 272 bytes

0 texture cache bytes allocated, 0 texture cache elements.


I have tried everything in the troubleshooting FAQ, from moving to internal storage, creating a shortcut ect.
Anyone? My problem seems similar to the person who asked below my original post. I just get taken out of the app when trying to run anything. I doubt it's his android version as mine has not been updated in years.

DanielFerVP
Posts: 4
Joined: Wed Aug 26, 2020 11:55 pm

Re: Troubleshooting crashes/sudden closes and other problems

Post by DanielFerVP » Wed Sep 02, 2020 8:48 am

Wolftheotter wrote:
Sat Aug 29, 2020 8:05 pm
Wolftheotter wrote:
Thu Aug 20, 2020 6:31 pm
Hey, having an issue with my Nvidia shield portable running drastic. Used to work wonderfully, but now when I try to start a game I am sent to my home screen. I am on 4.4.2 if that matters. I was able to find a drastic demo version online and it works fine.

The app itself does not close, and it still shows when I look at my multitasking trey. This is the only crash report I have, but it could be unrelated as whatever this bug is does not cause drastic to crash.

Unhandled SIG_SEGV in 'Tony Hawk's Proving Ground'
caused by instruction stmib r2, {r0 - r1} (at 6e502730), address 8732a26c
Version: r2.5.2.2a build 104
Reference: 5F64A5E4
Registers:
r00: 00000008
r01: 00000ECA
r02: 8732A268
r03: 03808A4C
r04: 7290E928
r05: 6B2E5008
r06: 7291CB50
r07: 00000088
r08: 6E5FC0F0
r09: 5F5E4EB4
r10: 5F5CB5F8
r11: 6294AB24
r12: 03808A4D
r13: 6294AA70
r14: 6E503E8C

Emulated ARM9:
Mode 00, IRQ 00000001, CPSR a000001f, PC 0200a1f0, cycles -0000001
r0: 00000000
r1: 0000001f
r2: 00000000
r3: 00000000
r4: 00000000
r5: 00000000
r6: 00000000
r7: 00000000
r8: 00000000
r9: 00000000
r10: 00000000
r11: 00000000
r12: 00000000
r13: 020baec8
r14: 02008d2f
r15: ffff0640
Debug instruction count: 0

Emulated ARM7:
Mode 00, IRQ 00000001, CPSR 8000001f, PC 00001158, cycles -0000001
r0: 04000000
r1: 03808788
r2: 00000080
r3: 00000007
r4: 0000001f
r5: 00000070
r6: 00000001
r7: 0380f958
r8: 0000ffff
r9: 00000002
r10: 00000000
r11: 00000000
r12: 00000006
r13: 0380f940
r14: 037f8454
r15: 00001f10
Debug instruction count: 0


Translation cache details:
main: 0x5f824000 - 0x60824000
main: 0 + 0 bytes
itcm: 0x60824000 - 0x60924000
itcm: 0 + 0 bytes
alternate: 0x60924000 - 0x60b24000
alternate: 632 + 272 bytes

0 texture cache bytes allocated, 0 texture cache elements.


I have tried everything in the troubleshooting FAQ, from moving to internal storage, creating a shortcut ect.
Anyone? My problem seems similar to the person who asked below my original post. I just get taken out of the app when trying to run anything. I doubt it's his android version as mine has not been updated in years.
I'm still with this problem, I don't know what's happened!

Post Reply