Page 4 of 5

Re: DraStic r2.5.0.4a test alpha

Posted: Sun Jul 16, 2017 3:48 am
by kaikun97
Exophase wrote:
AngryPotato wrote:Audio in MKDS is very slightly faster than audio running on a 3DS booted from a cart. Not sure of it's the 3DS or the emulator.

Additionally, sound in MarioKart DS, Pokemon Black 2, and Pokemon SoulSilver (haven't tested others) still plays when you've "closed" the DS at a slightly slower speed. When you "open" the DS in Pokemon Black 2 the onscreen stuff plays faster to try and catch up with the sound until they both reach the same spot, at which point it would play normally. In Pokemon SoulSilver, the audio and video play out of sync until it tries to play something else.

This is a bit stranger. If you boot New Super Mario Bros and close the lid while on the menu it repeats Mario's "Bye-bye" and "It'sa me, Mario" sound. In Super Mario 64 DS it repeats those lines with a ding between the lines.

This is with medium audio latency if that changes anything.


It looks like the lid sleep issue is due to a bug in DraStic's BIOS. This will be fixed next build.


This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?

Re: DraStic r2.5.0.4a test alpha

Posted: Sun Jul 16, 2017 6:09 am
by acid
Exophase wrote:
acid wrote:Whenever I pick a game from the list and select the continue last save option, Drastic crashes back to the main menu after loading the game. Using a zenfone 2 with an x86 Intel atom and 4gb ram if that helps at all. Tried with strange journey and solatorobo. Same result.

Edit:loading a game and then hitting the load savestate button makes it crash as well.


Does it happen if you create a new savestate and load it?

Can you see if a crash log was generated in /sdcard/DraStic ?


Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.

Re: DraStic r2.5.0.4a test alpha

Posted: Sun Jul 16, 2017 1:00 pm
by Exophase
kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.

Re: DraStic r2.5.0.4a test alpha

Posted: Mon Jul 17, 2017 6:02 am
by acid
Exophase wrote:
kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.

Re: DraStic r2.5.0.4a test alpha

Posted: Mon Jul 17, 2017 11:22 am
by xperia64
acid wrote:
Exophase wrote:
kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.


You savestate is definitely not broken. This is a bug specific to x86 devices on 2.5.0.4a.

Re: DraStic r2.5.0.4a test alpha

Posted: Fri Jul 21, 2017 12:13 am
by Exophase
acid wrote:
Exophase wrote:
kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.


I uploaded build 91, when it's available could you please see if it fixes the issue?

Re: DraStic r2.5.0.4a test alpha

Posted: Fri Jul 21, 2017 1:55 pm
by milesrotaru
It took me a while to get back to the problem area since I lost my original save but I can confirm that Solatorobo is running quite smoothly now.

Re: DraStic r2.5.0.4a test alpha

Posted: Fri Jul 21, 2017 6:07 pm
by acid
Exophase wrote:
acid wrote:
Exophase wrote:
That is correct.



Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.


I uploaded build 91, when it's available could you please see if it fixes the issue?


Yeah sure. The update hasn't popped up yet but as soon as it does I'll try it.

Re: DraStic r2.5.0.4a test alpha

Posted: Fri Jul 21, 2017 9:00 pm
by Exophase
It should be coming out now, hopefully.

Re: DraStic r2.5.0.4a test alpha

Posted: Sat Jul 22, 2017 5:41 am
by acid
Exophase wrote:It should be coming out now, hopefully.


It's working Exophase! Thanks! :D