DraStic r2.5.0.4a test alpha

Discuss anything about DraStic here.
User avatar
kaikun97
Posts: 445
Joined: Thu Dec 26, 2013 11:41 am
Location: England

Re: DraStic r2.5.0.4a test alpha

Postby kaikun97 » Sun Jul 16, 2017 3:48 am

Exophase wrote:
AngryPotato wrote:Audio in MKDS is very slightly faster than audio running on a 3DS booted from a cart. Not sure of it's the 3DS or the emulator.

Additionally, sound in MarioKart DS, Pokemon Black 2, and Pokemon SoulSilver (haven't tested others) still plays when you've "closed" the DS at a slightly slower speed. When you "open" the DS in Pokemon Black 2 the onscreen stuff plays faster to try and catch up with the sound until they both reach the same spot, at which point it would play normally. In Pokemon SoulSilver, the audio and video play out of sync until it tries to play something else.

This is a bit stranger. If you boot New Super Mario Bros and close the lid while on the menu it repeats Mario's "Bye-bye" and "It'sa me, Mario" sound. In Super Mario 64 DS it repeats those lines with a ding between the lines.

This is with medium audio latency if that changes anything.


It looks like the lid sleep issue is due to a bug in DraStic's BIOS. This will be fixed next build.


This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?
acid
Posts: 79
Joined: Wed Aug 07, 2013 2:47 pm

Re: DraStic r2.5.0.4a test alpha

Postby acid » Sun Jul 16, 2017 6:09 am

Exophase wrote:
acid wrote:Whenever I pick a game from the list and select the continue last save option, Drastic crashes back to the main menu after loading the game. Using a zenfone 2 with an x86 Intel atom and 4gb ram if that helps at all. Tried with strange journey and solatorobo. Same result.

Edit:loading a game and then hitting the load savestate button makes it crash as well.


Does it happen if you create a new savestate and load it?

Can you see if a crash log was generated in /sdcard/DraStic ?


Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.
Exophase
Posts: 1669
Joined: Mon Aug 05, 2013 9:08 pm

Re: DraStic r2.5.0.4a test alpha

Postby Exophase » Sun Jul 16, 2017 1:00 pm

kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.
acid
Posts: 79
Joined: Wed Aug 07, 2013 2:47 pm

Re: DraStic r2.5.0.4a test alpha

Postby acid » Mon Jul 17, 2017 6:02 am

Exophase wrote:
kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.
xperia64
Posts: 100
Joined: Fri Feb 28, 2014 7:41 pm

Re: DraStic r2.5.0.4a test alpha

Postby xperia64 » Mon Jul 17, 2017 11:22 am

acid wrote:
Exophase wrote:
kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.


You savestate is definitely not broken. This is a bug specific to x86 devices on 2.5.0.4a.
Exophase
Posts: 1669
Joined: Mon Aug 05, 2013 9:08 pm

Re: DraStic r2.5.0.4a test alpha

Postby Exophase » Fri Jul 21, 2017 12:13 am

acid wrote:
Exophase wrote:
kaikun97 wrote:This probably explains why I couldn't reproduce it, I assume using the Nintendo DS BIOS doesn't have this problem?


That is correct.

acid wrote:Creating a new savestate and loading it works. No crash log that I can see in the folder. What's the name of the file?

Edit: trying to load a proper in game save also crashes the emulator. Basically can't continue playing strange journey.


Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.


I uploaded build 91, when it's available could you please see if it fixes the issue?
milesrotaru
Posts: 6
Joined: Thu Mar 02, 2017 9:16 am

Re: DraStic r2.5.0.4a test alpha

Postby milesrotaru » Fri Jul 21, 2017 1:55 pm

It took me a while to get back to the problem area since I lost my original save but I can confirm that Solatorobo is running quite smoothly now.
acid
Posts: 79
Joined: Wed Aug 07, 2013 2:47 pm

Re: DraStic r2.5.0.4a test alpha

Postby acid » Fri Jul 21, 2017 6:07 pm

Exophase wrote:
acid wrote:
Exophase wrote:
That is correct.



Can you upload one of the files that causes the emulator to crash? It's possible something is wrong with them, or there's some other kind of access problem.


Sure. Here


Shin Megami Tensei - Strange Journey_8.dss
https://drive.google.com/file/d/0Bx3foC ... p=drivesdk

It's the quicksave. I can't load it on the new version.


I uploaded build 91, when it's available could you please see if it fixes the issue?


Yeah sure. The update hasn't popped up yet but as soon as it does I'll try it.

Return to “General”

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests